EV SSL Secured


×
×

News: Heartbleed Bug - OpenSSL Security Vulnerability Measures

Published: 04/12/2014 Back

You may heard about an OpenSSL bug Heartbleed affecting the Internet that have an impact of 2/3 of the companies worldwide. Heartbleed bug affects the OpenSSL library used by almost any online business to privately transfer data between the servers.

We want to let you know that SitesTen LLC took immediate actions to patch this security vulnerability and successfully eliminated any risk of unauthorized access to your account.

For your own protection we recommend you changing your current password, especially if you used the same password at other website that can be affected by the Hearbleed bug.

In addition if you are a VPS or dedicated server user be sure you patched the OpenSSL library. The affected versions are between 1.0.1 and 1.0.1f. In general if you have OpenSSL 1.0.1 that's built before April 7th, 2014 you're most probably affected. Feel free to contact our support team if you need help updating your VPS or dedicated server OpenSSL library.

SitesTen® is a registered trade mark of SitesTen LLC. All rights reserved.
SSL